Wednesday, November 19, 2008

ESX Server v3.01 - Connected Buffalo Terastation NAS via NFS

I have a set of Dell PowerEdge 2950 servers running VMware ESX 3.01 connected to my CX3-20 SAN with Q-Logic HBA's. I wanted to move old and test Virtual Machines to my 4.0 TB Buffalo Terastation Pro TS-RHTGL/R5 unit. To add 4TB of storage to my SAN would have cost me nearly $9,000, and instead, I'm using my cheaper and less robust $2,000 NAS unit. Obviously this is not the best solution for enterprise, but perfect for my testing and archiving.

This is how I configured my 4.0 TB Terastation II Rackmount with NFS and connected it to my ESX 3.01 servers.

1. I had to load the newest firmware from Buffalo for my unit so it would support NFS (I had 1.26 which does not support NFS). The newest firmware that I loaded is version 1.33. You can find yours and download it from http://www.buffalotech.com/support/downloads/

2. I setup the NFS service on the Terastation unit by logging into the web interface, clicked on NFS, clicked on Enable, entered my units IP and Subnet and then clicked Apply. I then clicked on Folders under NFS and checked the already Shared Folder I wanted to make available for NFS; mine happens to be vmware. Copy down the mount location, such as mine is /mnt/array1/vmware; you'll need this on the forth step. You also need to specify the client NFS devices that will be connecting to your NAS under the Registration section.
Here's the screenshots of the completed configuration:







3. I configured my VMware servers with a VMKernal adapter. You need the adapter to connect to iSCSI, NFS or VMotion. Under the servers Configuration tab, I went to Hardware-> Networking, clicked Add Networking..., selected VMKernal, picked the network adapter, and enter the IP address. I used the directions in this manual, on pages 33-37 and 194-197, to configure VMKernal adapter.

Here's the screenshot of the completed configuration:



4. Now that I configured the VMkernal adapter I was able to attach the NFS. Under the servers Configuration tab, I went to Hardware-> Stroage (SCSI,SAN, and NFS), clicked on Add Storage..., selected Network File System, entered my IP address 10.11.0.13, the mount point from step 2., /mnt/array1/vmware, and named my Datastore archive1. I used the directions in this manual, on pages 132-136, to configure Storage Device.

Here's the screenshot of the completed configuration:


Hope this helps someone else. Let me know who it works for you or if you found this useful.



Update 2009-08-26: Here's my terastation's drive configuration...

12 comments:

Marcus said...

Great Article, saved me lots of time trying to work out why ESXi wouldn't connect to my Terastatsion. Thanks again

Chuck said...

I'm running ESX 3.5u4 (build 176894) with a Terastation III (firmware v.1.06).

I was able to connect to the NFS share, however, my ESX hosts cannot read anything in the directory.

I'm trying to clone guest machines directly onto this NFS datastore as a temporary backup solution. However, whenever I try, I get an error: The virtual disk is either corrupted or not a supported format.

Ever seen that before?

Justin Bennett said...

I would suggest to look at the drive format that your terastation is configured for. That would be my best guess. Let me know if it helps. (I posted my drive configuration in the blog up above.)

ds said...

Hi, helpful information, but i tried it with ESXi 4 and a Buffalo TS-XL / Pro: I can connect, create folders and upload files, but can´t read them. The data browser shows only empty space.
Any idea what´s going wrong?

Dirk

Justin Bennett said...

Are you writting the data from your ESXi system or through another client (Windows Share/FTP) to to the NAS? Is the NAS have the latest firmware? Is you LUN over 2TB? Not sure, but that may be one of the limititations. I'll check back soon to see what's up.

There is a release note saying that data browser reports incorrect space. See below...

http://www.vmware.com/support/vsphere4/doc/vsp_esxi40_vc40_rel_notes.html

...
NAS datastores report incorrect available space

When you view the available space for an ESX/ESXi host by using the df (ESXi) or vdf (ESX) command in the host service console, the space reported for ESX/ESXi NAS datastores is free space, not available space. The space reported for NFS volumes in the Free column when you select Storage > Datastores on the vSphere Client Configuration tab, also reports free space, and not the available space. In both cases, free space can be different from available space.

ESX file systems do not distinguish between free blocks and available blocks, but always report free blocks for both block types (specifically, f_bfree and f_bavail fields of struct statfs). For NFS volumes, free blocks and available might can be different.

Workaround: You can check NFS servers to get correct information regarding available space. No workarounds are available for ESX/ESXi.
...

ds said...

yes, it´s > 2 TB and I try to use it as a datacenter, so try to access it direct from ESXi. The data is written by ESXi, just getting back/reading is impossible.

Also latest FW on Buffalo NAS is installed.

Benjamin said...

A new version of the firmware may help you to see your files... (since 1.20 is the problem resolve).

Fernando said...

Found on VMware comunities: We have provided a firmware update that resolves issues with ESX/ESXi and our Terastation III (TS-XL) series devices. The new firmware provides a "Kernel mode" option in the NFS settings. Update the firmware, and configure the NFS server with that kernel mode option checked, and that should resolve your issues.
Colin D.
Support Supervisor
Buffalo Technologies Inc.

Carl said...

Great post... Keep up the great work..

v/r

Carl

Paul L said...

Thanks. Now my ESXi 5.1 connects to my Terrastation Pro II as a backup destination for VMs. Running ones still run from the HDD in the Host

Justin Bennett said...

Sounds like a great use for it! I'd highly recommend configuring the e-mail function. We had two drives go bad in ours and lost all of our inactive VMs we had on it.

I'm also using a Iomegas 4 disk NAS (StorCenter ix4-200d) to do a robocopy from my workstation once a week as a personal backup.

Anonymous said...

Im getting the error that the mount request was denied by the NFS Server. Check that the Export Exists and that the client is permitted to mount it.
What am I missing?